Ipsec l2l tunnel between two routers

Download Template
Build an ipsec tunnel between Router A and Router B.

akonkol
February 16, 2012













%{--- Router A ---}%
!!ISAKMP PHASE 1
crypto isakmp policy 10
 hash md5
 authentication pre-share

crypto isakmp key %{shared_key}% address %{Router_B_outside_ip}%



!!PHASE 2
crypto ipsec transform-set %{transform_set_label}% esp-des esp-md5-hmac



!!Crypto map
crypto map %{crypto_map_name}% 10 ipsec-isakmp
 set peer %{Router_B_Outside_ip}%
 set transform-set %{transform_set_label}%
 match address 100

interface %{Router_A_external_interface}%
  crypto map %{crypto_map_name}%

access-list 100 permit ip %{Router_A_source_network}% %{Router_A_source_mask}% %{Router_B_source_network}% %{Router_B_source_mask}%


%{--- Router B ---}%
!!ISAKMP PHASE 1
crypto isakmp policy 10
 hash md5
 authentication pre-share

crypto isakmp key %{shared_key}% address %{router_a_outside_ip}%

crypto ipsec transform-set %{transform_set_label}% esp-des esp-md5-hmac

crypto map %{crypto_map_name}% 10 ipsec-isakmp
 set peer %{Router_A_outside_ip}%
 set transform-set %{transform_set_label}%
 match address 100


interface %{Router_B_external_interface}%
  crypto map %{crypto_map_name}%

access-list 100 permit ip %{Router_B_source_network}% %{Router_B_source_mask}% %{Router_A_source_network}% %{Router_A_source_mask}%

You must be logged in to comment.