EX2200-12C Branch Switch

Download Template
Example of a template for branch switch deployment

bdale
August 19, 2014





system {
    host-name %{system_hostname}%;
    auto-snapshot;
    domain-name client.network;
    time-zone %{system_timezone}%;
    root-authentication {
        encrypted-password "$1$ORHa8EX4$B9oxcOb5EnFW0GuTAXnG21"; ## SECRET-DATA
    }
    name-server {
        10.254.254.1;
        10.254.254.2;
    }
    login {
        class tech-admin {
            permissions all;
        }
        user tech {
            uid 2000;
            class tech-admin;
            authentication {
                encrypted-password "$1$Qb7CEjZ2$cidV8iQHKYUHt9tBSySgF0"; ## SECRET-DATA
            }
        }
        user onsite {
            uid 2001;
            class operator;
            authentication {
                encrypted-password "$1$MSbvHjW6$phgiX7ejiJbBMTOqw5dy21"; ## SECRET-DATA
            }
        }
    }
    services {
        ssh {
            root-login deny;
            protocol-version v2;
            rate-limit 3;
        }
    }
    syslog {
        archive size 5m files 10;
        user * {
            any emergency;
        }
        host 10.254.254.1 {
            any any;
        }
        file messages {
            any any;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
    archival {
        configuration {
            transfer-on-commit;
            archive-sites {
                "scp://netinfra@10.254.254.1/" password "$9$c/NrvLdVYcGiLhJDHqQzhSreK8LxNdwY"; ## SECRET-DATA
            }
        }
    }
    ntp {
        boot-server 10.254.254.1;
        server 10.254.254.1;
        server 10.254.254.2;
    }
}
chassis {
    alarm {
        management-ethernet {
            link-down ignore;
        }
    }
    auto-image-upgrade;
}
interfaces {
    interface-range USER-PORTS {
        member ge-0/0/0;
        member ge-0/0/1;
        member ge-0/0/2;
        member ge-0/0/3;
        member ge-0/0/4;
        member ge-0/0/5;
        member ge-0/0/6;
        member ge-0/0/7;
        member ge-0/0/8;
        member ge-0/0/9;
        member ge-0/0/10;
        member ge-0/0/11;
        unit 0 {
            family ethernet-switching {
                vlan {
                    members v10-data;
                }
            }
        }
    }
    interface-range UPLINK-PORTS {
        member ge-0/1/0;
        member ge-0/1/1;
        unit 0 {
            family ethernet-switching {
                port-mode trunk;
                vlan {
                    members v10-data;
                }
            }
        }
    }
    me0 {
        unit 0 {
            family inet;
        }
    }
    vlan {
        unit 10 {
            family inet {
                address %{vlan_10_address}%/24;
            }
        }
    }
}
snmp {
    location "%{snmp_location}%";
    community mgtmon {
        authorization read-only;
    }
    trap-group TRAP-MGT {
        version v2;
        targets {
            10.254.254.1;
        }
    }
}
routing-options {
    static {
        route 0.0.0.0/0 next-hop %{default_gateway}%;
    }
}
protocols {
    igmp-snooping {
        vlan all;
    }
    rstp {
        bridge-priority 4k;
        interface UPLINK-PORTS {
            mode point-to-point;
        }
        interface USER-PORTS {
            edge;
        }
    }
    lldp {
        interface all;
    }
    lldp-med {
        interface all;
    }
}
ethernet-switching-options {
    secure-access-port {
        interface USER-PORTS {
            mac-limit 3 action drop;
        }
    }
    port-error-disable {
        disable-timeout 60;
    }
    storm-control {
        interface all {
            level 1;
            multicast;
        }
    }
    bpdu-block {
        disable-timeout 30;
    }
}
vlans {
    v10-data {
        vlan-id 10;
        l3-interface vlan.10;
    }
}
poe {
    interface all;
}

You must be logged in to comment.