Cisco Switchports for Avaya IP Phones

Download Template
Shows the two methods - using LLDP or using DHCP Option 242 specified VLAN numbers in the L2Q and L2QVLAN options.

cstubbs
July 11, 2012
Eg. Fa, Gi

System number, usually only different in stacking systems etc

Blade/module in system #

Port on blade/module in system #

Voice VLAN Number

Data VLAN Number

!### USE LLDP NEGOTIATION IF SWITCH AND ALL PHONES SUPPORT IT ###
!
lldp run
!
interface %{INT_TYPE}%%{SYSTEM}%/%{BLADE}%/%{PORT}%
 description <<< Avaya IP Phone >>>
 switchport
 switchport mode access
 switchport nonegotiate
 switchport voice vlan %{VOICE_VLAN}%
 switchport access vlan %{DATA_VLAN}%
!
!### WITH NO LLDP, USE ONLY DHCP CONFIG ###
!
interface %{INT_TYPE}%%{SYSTEM}%/%{BLADE}%/%{PORT}%
 description <<< Avaya IP Phone >>>
 switchport
 switchport mode trunk
 switchport nonegotiate
 switchport trunk encapsulation dot1q
 switchport trunk native vlan %{DATA_VLAN}%
 switchport trunk allowed vlan %{VOICE_VLAN}%,%{DATA_VLAN}%
!

You must be logged in to comment.