Cisco IOS Router Template

Download Template
Basic IOS router template with EIGRP. OSPF/ISIS/iBGP/eBGP to be added later.

cstubbs
July 18, 2014
AS Number

Authentication key for EIGRP

Authentication key for HSRP/VRRP

!
ip routing
ip multicast-routing
ip multicast-routing distributed
!
interface loopback0
 description <<< Unique Router ID >>>
 ip pim sparse-dense-mode
 ip igmp version 3 
 no ip proxy-arp
 no shutdown
!
access-list 51 remark <<< Multicast Sink RP ACL >>>
access-list 51 deny 224.0.1.39
access-list 51 deny 224.0.1.40
access-list 51 permit 224.0.0.0 15.255.255.255
!
ip pim rp-address 192.0.2.1 51
!
! Router specific statement, do not use on switches
logging source-interface loopback0
!
ntp source loopback0
!
snmp-server source-interface traps loopback0
snmp-server source-interface informs loopback0
!
key chain FHRP-Auth
 key 0
  key-string %{FHRP_AUTH_KEY}%
!
key chain EIGRP-%{AS_NUMBER}%-Auth
 key 0
   key-string %{EIGRP_AUTH_KEY}%
!   
ip prefix-list Default-Route seq 10 permit 0.0.0.0/0
!
ip prefix-list ANY seq 10 permit 0.0.0.0/0 le 32
!
ip prefix-list RFC-1918 seq 10 permit 10.0.0.0/8 le 32
ip prefix-list RFC-1918 seq 20 permit 172.16.0.0/12 le 32
ip prefix-list RFC-1918 seq 30 permit 192.168.0.0/16 le 32
!
ip prefix-list IGP-Routes seq 10 permit 1.1.1.1/32
!
ip prefix-list EGP-Routes seq 10 permit 1.1.1.3/32
!
route-map EIGRP-%{AS_NUMBER}%-Ingress permit 10
 match ip address prefix-list IGP-Routes
!
route-map EIGRP-%{AS_NUMBER}%-Ingress permit 99
 match ip address prefix-list Default-Route
!
route-map EIGRP-%{AS_NUMBER}%-Egress permit 10
 match ip address prefix-list IGP-Routes
!
route-map EIGRP-%{AS_NUMBER}%-Egress permit 99
 match ip address prefix-list Default-Route
!
router eigrp %{AS_NUMBER}%
 eigrp log-neighbor-changes
 distribute-list route-map EIGRP-%{AS_NUMBER}%-Ingress in
 distribute-list route-map EIGRP-%{AS_NUMBER}%-Egress out
 passive-interface default
 no auto-summary
 !
!

You must be logged in to comment.