WAN CPE ISR G2

basic BGP config

slowbart
June 11, 2015
AAPT List Column Q

Site List Column T

Site List Column U

AAPT List Column K

Site List Column AE

Calculate this

Site List Column B

AAPT List Column N

AAPT List Column M

ip ssh version 2
crypto key generate rsa

service password-encryption
service sequence-numbers
!
hostname NSWBC-%{SITE_NAME}%
!

enable secret cisco
!
!
!
!
username cisco password cisco

!
ip ssh time-out 60
ip ssh version 2
!
!
class-map match-any RT_Hi
 match dscp ef
 match dscp cs5
class-map match-any RT_Lo
 match dscp cs4
 match dscp af41  af42  af43
class-map match-any ID_Hi
 match dscp cs3
 match dscp af31  af32  af33
class-map match-any ID_Lo
 match dscp cs2
 match dscp af21  af22  af23
class-map match-any BD
 match dscp cs6  cs7
 match dscp af11  af12  af13
 match dscp default
!
policy-map CPE_OUTPUT_TO_PE
 class RT_Hi
  priority percent 30
 class RT_Lo
  bandwidth percent 40
 class ID_Hi
  bandwidth percent 10
 class ID_Lo
  bandwidth percent 10
 class BD
  bandwidth percent 5
 class class-default
  set dscp cs1
  fair-queue
  queue-limit 128 packets
  random-detect dscp-based
  random-detect dscp 0 100 128
!
policy-map CPE_OUTPUT_TO_PE_PARENT_%{SHAPE_BW_Mbps}%Mbps
 class class-default
  shape average %{SHAPE_BW_x_1024000}%
   service-policy CPE_OUTPUT_TO_PE
!
interface GigabitEthernet0/0
 description AAPT Service %{AAPT_WAN_SERVICE_ID}%
 ip address %{NEC_WAN_IP}% 255.255.255.252
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 duplex auto
 speed auto
 service-policy output CPE_OUTPUT_TO_PE_PARENT_%{SHAPE_BW_Mbps}%Mbps
 no shut
!
interface GigabitEthernet0/1
 descr LAN switch dot1q trunk
 speed auto
 duplex auto
 no ip address
 no shut
!
int g0/1.1
encap dot1q 1
descr Data VLAN
ip address %{DATA_VLAN_IP}% 255.255.255.0
ip helper-address 10.31.100.11
no shut
!
int g0/1.100
encap dot1q 100
descr Voice VLAN
ip address %{VOICE_VLAN_IP}% 255.255.255.0
ip helper-address 10.31.100.11
no shut
!
interface range GigabitEthernet0/1/0 - 4
 description DOT1Q port to IP Phone
 switchport trunk native vlan 1
 switchport mode trunk
 switchport voice vlan 100
 spanning-tree portfast
!
interface range GigabitEthernet0/1/5 - 8
 description DOT1Q port to IP Phone
 switchport trunk native vlan 1
 switchport mode trunk
 switchport voice vlan 100
 spanning-tree portfast
!
router bgp %{BGP_ASN}%
 bgp log-neighbor-changes
 neighbor %{AAPT_WAN_IP}% remote-as 2764
 redist connected
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 %{AAPT_WAN_IP}%
!
no ip http server
no ip http secure-server
!
line vty 0 4
 privilege level 15
 logging synchronous
 transport input ssh
 transport output ssh
!
!
no ip dhcp excluded-address 10.10.10.1
!
no ip dhcp pool ccp-pool
!
!
no ip domain name
!
no access-list 23
no ip http access-class 
no banner exec 
!
no banner login 
!
line vty 0 15
login local
transport input ssh
!
no access-class in
!